SoftPixel Forum

Official community of the SoftPixel Engine and the SoftPixel Sandbox (REGISTRATION only with consultation with the Admin)
It is currently Wed Dec 13, 2017 10:15 pm

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Mon Feb 25, 2013 7:09 pm 
Offline

Joined: Sat Jul 14, 2012 3:50 pm
Posts: 89
Location: Germany
i've update spe to rev. 112. now i've three problems.

1. On cmake - build i get this error.
Quote:
CMake Error at CMakeLists.txt:790 (include):
1> include could not find load file:
1>
1> tests/RayTracingTests/CMakeLists.txt
1>
1>
1> CMake Configure step failed. Build files cannot be regenerated correctly. Attempting to stop IDE build.


I solve this by comment the line 790 out in file cmakelists.txt.

2. On cmake - generate i get this error.
Quote:
CMake Error at CMakeLists.txt:586 (add_library):
Cannot find source file:

sources/Resources/D3D11DefaultBasicShader2D(SM4).h

Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp
.hxx .in .txx


I solve this by comment these lines 91, 92 out in file cmakelists.txt.

3. By compiling the spe i get the link error of an unresolved symbol
Quote:
spDesktopRenderContext.obj : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol ""long __stdcall sp::SpWin32Callback(struct HWND__ *,unsigned int,unsigned int,long)" (?SpWin32Callback@sp@@YGJPAUHWND__@@IIJ@Z)" in Funktion ""protected: void __thiscall sp::video::DesktopRenderContext::registerWindowClass(void)" (?registerWindowClass@DesktopRenderContext@video@sp@@IAEXXZ)".
3>X:\Entwicklung\SDKs\SPESVN\trunk\Project\build\Debug\SoftPixelEngine.dll : fatal error LNK1120: 1 nicht aufgelöste externe Verweise.


Please add the necessary projects and files to the repository.

BTW:
cmake set the openal include dir to 'OpenAL/include/AL' and some project-files from the spe can't find 'AL/al.h' so it is better the include dir is set to 'OpenAL/include'

so that's it. :D

_________________
SPE 3.2 alpha (rev.119) (OpenGL), Win7, Intel E6600 2.4GHz, 6GB, nVidia GTX 560 1GB


Top
 Profile  
 
PostPosted: Mon Feb 25, 2013 7:40 pm 
Offline
Site Admin
User avatar

Joined: Sat Jul 07, 2012 5:58 pm
Posts: 540
Location: Germany
Thanks for the hint. I fixed it in rev. 113 :)

_________________
My latest project:
- The XièXiè Programming Language

My hardware:
- GIGABYTE GeForce GTX 670
- Intel Core i7 (Ivy-Bridge)
- 16 GB DDR3


Top
 Profile  
 
PostPosted: Wed Dec 24, 2014 5:32 am 
Offline

Joined: Wed Dec 24, 2014 5:30 am
Posts: 1
Sounds like you have much more experience in C++ then me. So why are you not able to compile the engine for MinGW? :roll:

This is a project specific convention. As you can see in the links below, in C++ this is a common convention ;)

_________________
Pass your MB7-701 braindumps and Test king in first try by using our guaranteed Olivet Nazarene University and olivet and best quality Rasmussen College


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group